• Welcome to ZD Forums! You must create an account and log in to see and participate in the Shoutbox chat on this main index page.

Nintendo Wi-Fi Issues (help from Computer Experts Needed)

Onilink89

Nyanko Sensei
Joined
Oct 18, 2007
Location
The Netherlands
I had this problem for years and i just hope someone can help me to fix this problem. And those guys at nintendo hotline are a bunch of noobs that don't have the knowledge about this.

My problem is, i can connect to nintendo wi-fi but most of the time unable to connect to other players. I'm just using a wireless router, with a good connection. (dsl connection)

According to nintendo this problem is caused by a firewall, blocking the connection. Now i have tried tons of things and reseached alot on the internet and still no succes.

There is nothing wrong with my Wii, because the same thing happens on my DS.

This is what i have done:
Latest firmware downloaded
Disabled all firewalls
Set the Wii on a static IP
Set the transmission mode on IEEE 802.11 B/G Mixed (appently nintendo wi-fi is not supported by on G only)
MAC adress filter is off
Dynamic DNS is off
Put Wii's Static IP * MAC adress in "DHCP clients"
Opened ports at "port forwarding" UDP&TCP 1 till 65535. ( Also specificly according to nintendo 29900, 28910, 29901, 29920, 80, 443 all on TCP)

Sources:
http://www.nintendo.com/consumer/wfc/en_na/ds/wrUnableToConnect.jsp
http://www.nintendo.com/consumer/wfc/en_na/ds/results.jsp?error_code=86420&system=Wii&locale=en_US
http://www.nintendo.com/consumer/systems/wii/en_na/onlineFirewall.jsp

The only weird thing is, everytime if i connect to nintendo wi-fi, it doesn't appear in my "network" on the computer. On my modem/router, there is a second client but i don't see the Static IP adress of the Wii. I Don't know if the Wii should be visable in your network.

I wanted to try nintendo wifi USB connector, but apperantly nintendo stopped making them. As an alternative i'm thinking buying a USB dongle and make it as a second acces point. But that would be a pain since i have to adjust alot of options on that.

So if you know what the cause is of my problem or any alternatives as a solution, please let me know.
 

zeldahuman

Graphic Designer
Joined
Feb 22, 2011
Location
Akkala
ok... so i advise you delete your connection settings and re-connect, because all of that stuff you did to it wont help.
On your computer, open the Command Prompt (CMD) and enter IPCONFIG find the label Wireless LAN adapter Wireless Network Connection: and find Default Gateway take that IP address (it's usually a code like 10.11.12.3) and enter it into the URL bar at the top of your Internet Browser. A pop-up should appear saying to enter a password to gain access to your Wireless Router's Settings. Hopefully you know it. and once you're in, flip through the options until you find the option Wireless Channel. Set that to either 1 or 11, and try connecting. if that doesn't work, i don't know what to tell you.

Good Luck,
~Zeldahuman
 

Ikana

Trollkastel
Joined
Dec 3, 2009
Location
Ikana Canyon
It depends on what security system you have ( the ds is real bad with this one), I used to have this problem all the time with my DS. Well my wifi worked with my wii but for some reason it wouldn't work with my DS. Well I had to search up on why my ds wouldn't work with my wifi and it turns out that if your security system doesn't support a connection with your ds then all you can do is get another Security system or shut off the one you have. I don't remember which settings it is but I do believe WEP is the one that supports both Wii and DS games.
 

Emma

Eye See You
Site Staff
Joined
Nov 28, 2008
Location
Vegas
Gender
Female
It depends on what security system you have ( the ds is real bad with this one), I used to have this problem all the time with my DS. Well my wifi worked with my wii but for some reason it wouldn't work with my DS. Well I had to search up on why my ds wouldn't work with my wifi and it turns out that if your security system doesn't support a connection with your ds then all you can do is get another Security system or shut off the one you have. I don't remember which settings it is but I do believe WEP is the one that supports both Wii and DS games.
The DS is notorious for not working well with Wi-Fi. McDonalds did a whole promotional thing where you could bring in your DS and use them in the restaurants with WiFi, but it bombed. No one's DS would work in them. This happens on a crapton of wifi networks, especially public ones, or those with certain special security systems. Most specifically those that have a terms of use thing you have to confirm, which is insanely common in public wi-fi. As the DS doesn't have an interface to confirm that, it just doesn't work. That was the issue with McDonalds. Similar problems happen with home wi-fi connections. If it happens at home, changing your security to WEP should fix most problems. Don't let the security nuts fool you, the other, more advanced security types don't really offer that much more protection. Yes, it can be hacked. But the chances are so small it's not even worth bothering with. Besides, the range of wifi for at-home routers isn't much. If you have a large lot you live on, it probably won't make it reliably past the property line. Even just the next building over would be too weak to pick up the signal well enough to make a worthwhile connection.

In regards to the OP, try switching to WEP. It's adequate protection and it should work on all consoles and handhelds. Also, make sure you're actually logging into your router's settings page, not just your computer's settings. A router has its own firewall independent of your computer's. Depending on your router, you might be able to reduce your firewall settings. Or you could just turn it off, and leave it off. It's mainly your computer that needs a firewall anyway, and you can have an independent firewall on it that's much more customizable.
 
Joined
Sep 15, 2009
Location
Cali For Nuh
Nintendo.com's help page, will be very helpful. Tech support gave me a phone call last time it wasn't working and walked me through everything. IF nothing else works I suggest you give them a try.
 

Emma

Eye See You
Site Staff
Joined
Nov 28, 2008
Location
Vegas
Gender
Female
Nintendo.com's help page, will be very helpful. Tech support gave me a phone call last time it wasn't working and walked me through everything. IF nothing else works I suggest you give them a try.
Also if you never logged into your wireless router before, or don't know how, they have a very handy guide on to how to access it. Helped me out.
 

Onilink89

Nyanko Sensei
Joined
Oct 18, 2007
Location
The Netherlands
ok... so i advise you delete your connection settings and re-connect, because all of that stuff you did to it wont help.
On your computer, open the Command Prompt (CMD) and enter IPCONFIG find the label Wireless LAN adapter Wireless Network Connection: and find Default Gateway take that IP address (it's usually a code like 10.11.12.3) and enter it into the URL bar at the top of your Internet Browser. A pop-up should appear saying to enter a password to gain access to your Wireless Router's Settings. Hopefully you know it. and once you're in, flip through the options until you find the option Wireless Channel. Set that to either 1 or 11, and try connecting. if that doesn't work, i don't know what to tell you.

Good Luck,
~Zeldahuman
Thanks for the help but, I already adjusted it to channel 11 a long time ago. I got this info from Nintendo directly.

And yes i know how to acces my router, I think thats obvious since I stated that I changed so many setting like NAT, Mac filter, Router Firewall, Transmission Mode ect. Especialy when it comes to port forwarding, that can only be adjusted directly from the router.

What form of security are you using on your Wi-Fi? I've heard that some games have issues if you use anything other than basic WEP.
Yep everything is set on basic WEP on the router, so thats not my issue.

Nintendo.com's help page, will be very helpful. Tech support gave me a phone call last time it wasn't working and walked me through everything. IF nothing else works I suggest you give them a try.
Not here in holland, the tech support of nintendo of Benelux does not know anything. First its was like "Call your ISP". I call ISP en then they were like "call Nintendo".
Suddenly they told me my wi-fi of my wii might be broken. They wanted that i would send my Wii to them. Last time i did that, all the data was gone.

Also if you never logged into your wireless router before, or don't know how, they have a very handy guide on to how to access it. Helped me out.
Like i said before to zeldahuman, its obvious that I know how to acces my router. To adjust those settings is done directly from the router itself.


But still thnx for the effort and help you guys, but I might have accidently fixed the problem myself. After days of googling for info about this, i came across a thread on the nintendo techforums something about "Optimal settings for streaming Netflix through Wii".

There was this guy that suggested to use an OpenDSN server rather then your own primary and secondary DSN, since its faster then your own ISP. I was like, its worth trying...and somehow it worked! Now i don't know what DSN servers exactly is, but i assume that my own DSN servers were blocking the connections of other players somehow. Or my own DSN servers are just way too slow or something. I really hope it just stays this way, because i'm overjoyed! As a last resort i was planning to switch from an ISP just because of the modem (which is at the same time my router).
 

Emma

Eye See You
Site Staff
Joined
Nov 28, 2008
Location
Vegas
Gender
Female
Well having this information here still will help anyone else with the same problem. So it doesn't hurt that all this info is here.
 

Users who are viewing this thread

Top Bottom