• Welcome to ZD Forums! You must create an account and log in to see and participate in the Shoutbox chat on this main index page.

Animated Avatars

Cfrock

Keep it strong
Joined
Mar 17, 2012
Location
Liverpool, England
I've seen animated avatars on the forum in the past. Some users have them right now, in fact. But when I upload a .gif image as my avatar it isn't animated.

I did some light reading online and checked if the issue was the filesize, the image size, or both. It wasn't, as far as I can tell. It's possible the issue is related to the ImageMagik extension. It's possible that the extension (assuming it was installed) has to be reinstalled following the big update a while back. I don't know if this is an easy fix or a major headache, but if we can get animated avatars working again I'd be a very happy boy :rosa:
 
Yours confuses me greatly because it was animated when I was on my laptop but it isn't now that I'm on my desktop.

I just want my happy Blastoise to dance in the rain :rosa:
Yeah it doesn't always move for me either, I assumed it was a mobile thing since that's what I use 100% of the time and have no comparison.
 
I don't have as fun of image editing access right now sadly, but I think the dimensions of the gif play a role. Like filesize definitely does, if it's too big, the uploader will flatten the image and make it static, maybe even jpeg it because reasons. But xenforo handles avatars strangely and instead of just normally scaling images, it has multiple rendered versions of the avatar (small, medium, large, original). Like I look at the url for the original of your avatar and the animation is present. When I did Spirit's avatar, I made the gif dimensions 192x192 as that is the dimension of the pre-rendered large avatar.

If you have access to an image editing program, first unoptimize the gif if it's optimized. Temporarily change the colors to RGB (gif's are indexed because of their color palette), and then group all the layers and scale it. Then reindex it and reoptimize. If that makes sense.

I still have this portable version of GIMP that I hate, if you wanted to see if I could try.
 

Cfrock

Keep it strong
Joined
Mar 17, 2012
Location
Liverpool, England
Let me know if this works--

No, I've got it on right now and it's still static Thanks for giving it a go, though :)

I was messing about before, resizing it to 96 x 96 and getting the filesize below 150Kb and then below 100Kb, but not only do I not know how computers work, I don't know how images work, so I couldn't tell if what I was doing was relevant or not. With it being a .gif as well just added to the amount of things I don't know.

I'll give it a go doing what you suggested. If anyone's going to go mad fiddling with this it should be me.
 

Cfrock

Keep it strong
Joined
Mar 17, 2012
Location
Liverpool, England
Aw, I'm sorry it didn't work. :( Well, I would definitely say it's something to do with xenforo's avatar scaling system.
Yeah, that's what it sounds like from the forum posts and such I've been reading. Some people have them working on profiles but not posts, others have it the other way around, and for some they work for some users and not others. I think Xenforo gets drunk whenever it sees a .gif avatar and you just have to hope for the best.
 
Well for a final note, you can access the different versions of your avatar by changing one thing in the url, so when you're testing the animations, you can look at all versions. It seems the medium version is what is used in the postbit.

https://zeldadungeon.net/forum/data/avatars/m/2/2282.jpg?1578001753 this is the link to my avatar from my postbit, I got it by just copying the image location, you know the drill.

After /avatars there is an /m. That's the scaler. Switch the "m" for "s" "l" or "o" to get the other rendered sizes. When you upload a new avatar, you can test that. When the animation is working for a certain size, wherever that size is used on the forum, the animation will work. Medium size seems most important.
 

Users who are viewing this thread

Top Bottom